Facebook Pixel
EmpowHER Guest

Implantation bleeding or Early AF? Please Help!

By Anonymous February 10, 2013 - 9:25am
Rate This

My LMP started on January 13th. I lasted 3 days. (which is normal for me). We had unprotected sex on Jan. 18, 25, & 31. On Feb. 8 I began spotting, brown in color and the next day I began having period like cramps, but still only spotting. Nothing on my underwear, just when I wiped. Last night, when I wiped, there was a tiny spec of very light red but mostly brown, and again this morning back to completely brown. My AF is due For Feb. 14. So I am just wondering does this sound like implantation bleeding, or early AF? Again, I am having NO FLOW at all, just light spotting when I wipe.. thanks! (: Sorry for TMI!

Add a Comment2 Comments

Hi Anon,

It could be implantation bleeding since it typically occurs one week before your period is due. And If your next period is due on Feb 14, then you can actually probably test for pregnancy already. However, for a more accurate result, you should wait to see if your period does come down and then test if it does not. 

Please keep us posted,


February 10, 2013 - 6:04pm
(reply to Rosa Cabrera RN)

Hi Rosa, there has been slight change in color, it is not very dark red, although still no flow at all, only notice it when I sit on toilet or wipe.. Idk if its my period or not. I tested last night and BFN, so I may test again if it continues this way with no flow.

February 10, 2013 - 6:38pm
Enter the characters shown in the image.
By submitting this form, you agree to EmpowHER's terms of service and privacy policy
Add a Comment

All user-generated information on this site is the opinion of its author only and is not a substitute for medical advice or treatment for any medical conditions. Members and guests are responsible for their own posts and the potential consequences of those posts detailed in our Terms of Service.